51阅读吧 - 为您打造专业优质的文章分享平台!
您的当前位置: 51阅读吧 >

工行支付存在漏洞|火狐3.5版被指推出太匆忙:存在50多个漏洞

NO.1 火狐3.5版被指推出太匆忙:存在50多个漏洞

北京时间7月3日消息,据国外媒体报道,美国非盈利机构Mozilla本周二发布了其火狐(Firefox)3.5版浏览器后,一些用户和网络安全专家指出,该版本存在着50多个技术漏洞,因此存在“匆忙推出”之嫌。这些用户还表示,希望Mozilla尽快推出修复上述漏洞的火狐3.5.1版。

据悉,火狐3.5版的JavaScript性能表现更为优异,并具备隐私浏览功能。与老版本相比,火狐3.5版能够更好支持各网站的视频和音频内容播放。 Mozilla称,目前全球火狐活跃用户已超过3亿,Windows、Linux和苹果Mac OS X操作系统的用户皆可使用火狐3.5版,该浏览器所支持的语言超过70种。

但一些已在使用火狐3.5版的用户表示,该版本至少存在着50多个技术漏洞,用户经常遇到火狐3.5版启动时间过长、使用过程中崩溃(TraceMonkey JavaScript引擎中的漏洞所致)等现象。

有报道称,Mozilla技术开发人员正抓紧时间修复上述技术漏洞,并有望于本月中旬或下旬发布火狐3.5.1版。其他人士则表示,火狐3.5.1版很可能只是修复当前版本的一些主要漏洞,要完全修复这些漏洞,可能要等到火狐3.5.2版才能得到解决。

Mozilla今年3月初曾表示,将把火狐3.1的版本号直接改为3.5,以表明同3.0版相比,3.1版各项性能已经有了重大改进和调整。但由于遇到一些技术问题,火狐3.5正式版的发布时间已被多次推迟。

业界人士认为,虽然火狐3.5版原定发布时间被一再推迟,但本周二推出的该版本仍有匆忙推出之嫌。尽管如此,火狐3.5版发布,仍受到了全球网民的追捧。截止今天上午,火狐3.5版全球下载量已超过900万次。(编译/中涛)

NO.2 WordPress 4.0以下版本存在跨站脚本漏洞

该漏洞是由芬兰IT公司Klikki Oy的CEO Jouko Pynnonen发现的,只存在于Wordpress4.0以下的版本中。据调查得知全球有86%的Wordpress网站都感染了这一漏洞,也就意味着全球数百万的网站都存在着潜在的危险。一些知名网站也使用了Wordpress软件,如Time、UPS、NBC Sports、CNN、Techcrunch 和FreeBuf:)

漏洞概述

WordPress中存在一系列的跨站脚本漏洞,攻击者利用跨站脚本伪造请求以欺骗用户更改登录密码,或者盗取管理员权限。

如Jouko Pynnonen解释道:

当博客管理员查看评论时,评论中的漏洞代码会自动在其Web浏览器上运行。然后恶意代码会偷偷接管管理员账户,从而执行管理员操作。

为了证明他们的观点,研究人员创建了一个漏洞利用程序(exploits)。利用这个exploits,他们创建了一个新的WordPress管理员账户,改变了当前管理员密码,并在服务器上执行了攻击PHP代码。

漏洞分析

问题出在wordpress的留言处,通常情况下留言是允许一些html标签的,比如、等等,然而标签中有一些属性是在白名单里的,比如标签允许href属性,但是onmouseover属性是不允许的。

但是在一个字符串格式化函数wptexturize()上出现了问题,这个函数会在每一个留言上执行,函数的功能是把当前的字符转义成html实体,比如把“”转义为“”。为了防止干扰html格式,wptexturize()首先会以html标签为标准把文本分成若干段,除了html标签,还有方括号标签比如[code]。分割的功能是由下列正则表达式完成的。

在wp-includes/formatting.php代码的第156行:

$textarr = preg_split('/(<.*>|[.*])/Us', $text, -1,                         

PREG_SPLIT_DELIM_CAPTURE);

但是如果文章中混合着尖括号<>和方括号[]会造成转义混淆,导致部分代码没有转义。

攻击者可以通过这个漏洞在允许的HTML标签中注入样式参数形成XSS攻击,比如通过建立一个透明的标签覆盖窗口,捕捉onmouseover事件。

漏洞利用测试

以下代码可以用于测试

[<a href="test" title="]">[" NOT VULNERABLE]

修复建议

这一漏洞很容易被攻击者利用,WordPress官方建议用户尽快更新补丁,而在新版WordPress 4.0.1已经修复了所有的漏洞。

WordPress官方于11月20日发布了官方补丁,目前大多数的WordPress网站上都会收到补丁更新提醒通知;如果有一些其他原因使得你无法更新补丁,Klikki Oy公司还提供了另外一个解决方案(workaround)可以修复该漏洞。

wptexturize可以通过在wp-includes/formatting.php开头增加一个返回参数避免这个问题:

function wptexturize($text) {        

return $text;                  // ADD THIS LINE        

global $wp_cockneyreplace;

额外提醒

如果你使用的是WP-Statistics WordPress插件,你也应该更新补丁。因为这些插件上也存在跨站脚本漏洞,攻击者同样可以实施攻击。

NO.3 McAfee Framework存在远程格式串处理漏洞

受影响系统: McAfee ePolicy Orchestrator 4.0 McAfee Framework <= 3.6.0.569 描述: -------------------------------------------------------------------------------- BUGTRAQ ID: 28228 McAfee Framework是McAfee ePolicy Orchestrator中所实现的用于创建各种McAfee产品服务的框架。 McAfee Framework所安装的applib.dll库中的logDetail函数缺少必要的格式参数便调用了vsnwprintf,远程攻击者可能利用此漏洞控制服务器。 在McAfee ePolicy Orchestrator中可通过发送单个带有畸形sender、package或computer字段的UDP报文来触发这个漏洞。输出日志文件Agent_HOSTNAME.log位于Db文件夹中。 <*来源:Elazar Broad (elazarb@earthlink.net) 链接:http://marc.info/?l=bugtraq&m=120535402014666&w=2 http://secunia.com/advisories/29337/ *> 建议: -------------------------------------------------------------------------------- 厂商补丁: McAfee ------ 目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本: http://www.mcafee.com/

NO.4 Gnome Evolution存在显示加密消息格式串处理漏洞

受影响系统:
GNOME Evolution 2.12.3 描述:
Evolution是个人和工作组信息管理解决方案,可使用在Linux和Unix操作系统下,集成Email、日历、会议安排、联系人管理等功能。 Evolution的mail/em-format.c文件中的emf_multipart_encrypted()函数在显示加密邮件消息的“Version:”等字段时存在格式串漏洞,如果用户受骗打开了特制邮件消息的话,就可能导致执行任意指令。 厂商补丁:
Debian已经为此发布了一个安全公告(DSA-1512-1)以及相应补丁:
DSA-1512-1:New evolution packages fix arbitrary code execution
链接:http://www.debian.org/security/2008/dsa-1512

上一篇:社区健康教育工作制度|社区健康教育工作方案 上一篇:独角戏|独角戏
与该文相关的文章

温馨提示:如果您对51阅读吧有任何建议,请通过网站联系邮箱向我们反馈,感谢各位的建议与支持!